Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

VPT Crashing in Test Play and Online Play

edited May 2014
I hope that this has happened to someone else, not to be a schaedenfreunde sort of thing, but because you managed to fix it.

It seems like all of a sudden after finished creating a deck in the MtG module my VPT started crashing whenever I went to Test Play or Online play. I get to the part where I load the deck I want to use and click "Start". VPT immediately closes with no error messages from windows or anything. Tried a couple fresh installs with the VPT and module, tried the arcane towers module as well and it still crashes at the same point.

Comments

  • cowboy, I have this bug on virtual machine with WindowsXP x64 too.
    I will try to fix this bug in next build.
  • Howdy!
    This product seems to have amazing potential.
    The instructions are very clear to follow. Thank you!
    I have successfully installed the application, the magic module (v0.8.6), and set the image locations.
    Deck Editor works great.

    When I attempt to play test the deck, the application closes completely.
    This log file is generated in the Program Files location:
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x77a55f2b, pid=2564, tid=2588
    #
    # JRE version: Java(TM) SE Runtime Environment (7.0_51-b13) (build 1.7.0_51-b13)
    # Java VM: Java HotSpot(TM) Server VM (24.51-b03 mixed mode windows-x86 )
    # Problematic frame:
    # C [ntdll.dll+0x55f2b]
    #


    --------------- T H R E A D ---------------

    Current thread (0x033ef000): JavaThread "main" [_thread_in_native, id=2588, stack(0x00040000,0x00140000)]

    siginfo: ExceptionCode=0xc0000005, reading address 0xbdbbf80e

    Registers:
    EAX=0x00280000, EBX=0x000040c7, ECX=0x0fbee367, EDX=0xbdbbf80e
    ESP=0x00139394, EBP=0x00139464, ESI=0x0fbee35f, EDI=0xf02be000
    EIP=0x77a55f2b, EFLAGS=0x00010206

    Top of Stack: (sp=0x00139394)
    0x00139394: 77bc998e 00008000 00000000 00280000
    0x001393a4: 00282cb0 00000000 00000000 00000000
    0x001393b4: 023e7650 00139400 97ed40c7 00000030
    0x001393c4: 00000099 00282cb0 00000000 0fbee367
    0x001393d4: 022e2134 0000003a 0bba37c8 000007ff
    0x001393e4: 000000b7 0bba37c8 00000000 00000000
    0x001393f4: 00000000 02000002 bdbbf80e 69615751
    0x00139404: 6e6f4374 69746964 00000000 74736544

    Instructions: (pc=0x77a55f2b)
    0x77a55f0b: 0f 85 4a 45 03 00 0f b7 1e 3b 5d d4 0f 82 67 4a
    0x77a55f1b: 02 00 8d 4e 08 8b 39 89 7d b8 8b 56 0c 89 55 98
    0x77a55f2b: 8b 12 8b 7f 04 3b d7 0f 85 3f 4a 02 00 3b d1 0f
    0x77a55f3b: 85 37 4a 02 00 29 58 78 8b 80 b8 00 00 00 85 c0


    Register to memory mapping:

    EAX=0x00280000 is an unknown value
    EBX=0x000040c7 is an unknown value
    ECX=0x0fbee367 is an unknown value
    EDX=0xbdbbf80e is an unknown value
    ESP=0x00139394 is pointing into the stack for thread: 0x033ef000
    EBP=0x00139464 is pointing into the stack for thread: 0x033ef000
    ESI=0x0fbee35f is an unknown value
    EDI=0xf02be000 is an unknown value


    Stack: [0x00040000,0x00140000], sp=0x00139394, free space=996k
    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
    C [ntdll.dll+0x55f2b]
    C [ntdll.dll+0x55af0]
    C [AcXtrnal.DLL+0x9d45]
    C [Playtable.exe+0xabf0a4]

    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
    j vpt.common.GameModule.playSound(Ljava/lang/String;)V+0
    j vpt.scene.GraphicsWindow.soundPlayed([Ljava/lang/String;)V+26
    j vpt.state.StateController.playSounds([Ljava/lang/String;)V+31
    j vpt.state.StateController.playSounds(JJ[Ljava/lang/String;)V+288
    j vpt.state.StateController.commandApplied(Lvpt/state/State;Lvpt/state/TransactionData;)V+62
    j vpt.state.State.apply(Lvpt/state/State$CommandData;)Lvpt/state/TransactionData;+199
    j vpt.state.State.internalExecute(I[B)Z+38
    j vpt.state.StateController.execute(Lvpt/state/StateCommand;[B)Z+68
    j vpt.state.commands.BaseVariantMapCommand.execute(Lvpt/common/VariantMap;)Z+35
    j vpt.playscene.StartGameDialog.start()V+151
    j vpt.playscene.StartGameDialog.access$000(Lvpt/playscene/StartGameDialog;)V+1
    j vpt.playscene.StartGameDialog$1.onClicked(I)V+10
    v ~StubRoutines::call_stub
    j vpt.widgets.Window.showModal()V+0
    j vpt.windows.DeckEditor.showPlayWindow(Lvpt/state/StateController;)V+15
    j vpt.windows.DeckEditor.showTestHand()V+116
    j vpt.windows.DeckEditor$14.onTriggered()V+4
    v ~StubRoutines::call_stub


    VM Arguments:
    jvm_args: -esa -esa -esa -Xincgc -ea -esa -Xms64m -Xmx384m vfprintf exit abort
    java_command:
    Launcher Type: generic

    Environment Variables:
    PATH=C:\Program Files\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\idmu\common;C:\Windows\System32\WindowsPowerShell\v1.0\
    USERNAME=pUser
    OS=Windows_NT
    PROCESSOR_IDENTIFIER=x86 Family 6 Model 42 Stepping 7, GenuineIntel



    --------------- S Y S T E M ---------------

    OS: Windows 7 Build 7600

    CPU:total 2 (2 cores per cpu, 1 threads per core) family 6 model 42 stepping 7, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, avx, aes, tsc, tscinvbit

    Memory: 4k page, physical 3145208k(1934952k free), swap 6288672k(5067800k free)

    vm_info: Java HotSpot(TM) Server VM (24.51-b03) for windows-x86 JRE (1.7.0_51-b13), built on Dec 18 2013 19:04:14 by "java_re" with unknown MS VC++:1600

    time: Sat Jun 28 01:03:56 2014
    elapsed time: 57 seconds

    Any clues?
    I experienced this java error running VPT on VMWare Fusion Win7Enterprise (x86)
  • edited April 18
    Yes, it happened to me several times, too! Solitaire and deck testing causes VPT to crash. But also on simple deck editing.
    apparently, it has to do only with certain cards -for example, most of the Return to Ravnica block cards can't even stand to be looked at! I mean, I just click on them and *poof!* crash it goes.
    I am on WIN10
Sign In or Register to comment.